Обновления и и улучшения форума. Часть 2

Ваши предложения по работе и наполнению форума и портала "Мой Филдер", сообщения об ошибках
Аватара пользователя
panfiloff
Администратор
Черный бумер
Сообщения: 1150
Зарегистрирован: 26 дек 2009, 15:43
Откуда: Россия, Новосибирск
Благодарил (а): 32 раза
Поблагодарили: 17 раз
Контактная информация:

14 дек 2017, 12:21

zorkpos писал(а):
14 дек 2017, 10:58
Да было дело пару дней выкинул из сессии. благо запоминание учетки есть во всех браузерах.
думаю что это пока связано с настройками php когда будет сайт работать без правок, тогда не будет выкидывать.
Итак, давайте последовательно попробуем решить проблему, когда логин-пароль не подставляются автоматом в различных браузерах. На сайте уже все настроено в плане корректной работы, он тут не причем, это я могу гарантировать. У меня все подставляется как надо, проверено в следующих браузерах и ОС:
1) iOS 11.2.1 - Safari, Miranda, Chrome
2) Android 7.1.1 - Chrome, Mi Browser
3) Windows 7, Windows 10 - Chrome, Opera, Internet Explorer
Я могу, конечно, поставить еще с десяток браузеров на разных устройствах, но, думаю, результат будет тот же - все будет нормально входить при правильной настройки браузера и правильном сохранение логина-пароля нашего форуму в нем.

Итак, начнем с того, с основного вопроса - "почему раньше все подставлялось, а сейчас нет, хотя на других сайтах все ок". Потому что на сайте было много обновлений, и основное из них, которое могло повлиять на автовход на сайт - переезд с http на https. Дело в том, что все ваши сохранения логина-пароля были актуальны для сайта http://myfielder.ru, а сейчас работает только вариант https://myfielder.ru, на который должен быть редирект с небезопасного протокола. НО!!! Он может не сработать, если у вас по каким-то причинам плохо почищены куки и кэш в браузере, вы можете сначала попасть на форум по http а при попытке залогиниться перекинет на https и автоподстановка может не сработать. Несколько путанно возможно пояснил, ну уж как смог. Так что же делать, чтобы все корректно работало?

1) Зайдите на форум по https://myfielder.ru
2) Обязательно убедитесь, что вы работаете по ssl - должен быть значек закрытого "замочка" в адресной строке браузера
3) Очистите поглубже (минимум на неделю) куки и кеш браузера. На форуме в подвале есть ссылка на чистку куков, ее лучше не использовать, чистите все средствами браузера.
4) Перейдите на авторизацию на форуме. Если логин-пароль не подставлены в соответствующих полях, введите их, поставьте галочку в "запомнить меня" и нажмите "вход". Когда браузер предложит сохранить пароль, обязательно согласитесь! Только в этом случае автоподстановка будет работать корректно.
5) Попробуйте выйти и снова войти - если все было сделано верно, логин и пароль должны автоподставиться

Надеюсь, что у многих после выполнения этих действий проблема автовхода решится.
Toyota Corolla Fielder 1.5 X, NZE-141, 1NZ, CVT, 2006
Аватара пользователя
awwa
Автомобилист
Сообщения: 100
Зарегистрирован: 15 май 2010, 23:17
Откуда: Новосибирск
Поблагодарили: 1 раз

14 дек 2017, 13:15

Упорно на сайт заходил через старую закладку в которой адрес начинался на http:/ , добавил S. Теперь захожу нормально. Куки и кеш не чистил.
Fielder 1,8 2003
Лучшая машина это та, которая твоя и за которую ничего не должен.
Аватара пользователя
panfiloff
Администратор
Черный бумер
Сообщения: 1150
Зарегистрирован: 26 дек 2009, 15:43
Откуда: Россия, Новосибирск
Благодарил (а): 32 раза
Поблагодарили: 17 раз
Контактная информация:

14 дек 2017, 13:19

awwa писал(а):
14 дек 2017, 13:15
Упорно на сайт заходил через старую закладку в которой адрес начинался на http:/ , добавил S. Теперь захожу нормально. Куки и кеш не чистил.
Во, первый пошел :co_ol:
Toyota Corolla Fielder 1.5 X, NZE-141, 1NZ, CVT, 2006
Аватара пользователя
kudrik34
Шофер
Сообщения: 676
Зарегистрирован: 06 окт 2013, 14:48
Откуда: Карасук НСО
Благодарил (а): 4 раза
Поблагодарили: 11 раз

14 дек 2017, 14:33

У меня каждый раз после нажатия на кнопку филдер , нужно авторизовываться, я один такой?
Олег
https://yadi.sk/d/o6slUfa03MS2wX инструкции качаем тут
Toyota Corolla Fielder 2008г. ZRE142G V-1.8 "S" белый или просто "ФИЛЯ"
Аватара пользователя
awwa
Автомобилист
Сообщения: 100
Зарегистрирован: 15 май 2010, 23:17
Откуда: Новосибирск
Поблагодарили: 1 раз

14 дек 2017, 16:12

kudrik34 писал(а):
14 дек 2017, 14:33
У меня каждый раз после нажатия на кнопку филдер , нужно авторизовываться, я один такой?
Не один :-) Две страницы этой темы посвящены этому. У меня такое было, потому что я входил через закладку, которая была еще сделана до переезда сайта, а в ней было просто http. Я подкорректировал адрес в старой закладке - добавил S
htpps.jpg
Fielder 1,8 2003
Лучшая машина это та, которая твоя и за которую ничего не должен.
Аватара пользователя
kudrik34
Шофер
Сообщения: 676
Зарегистрирован: 06 окт 2013, 14:48
Откуда: Карасук НСО
Благодарил (а): 4 раза
Поблагодарили: 11 раз

14 дек 2017, 16:56

awwa писал(а):
14 дек 2017, 16:12
kudrik34 писал(а):
14 дек 2017, 14:33
У меня каждый раз после нажатия на кнопку филдер , нужно авторизовываться, я один такой?
Не один :-) Две страницы этой темы посвящены этому. У меня такое было, потому что я входил через закладку, которая была еще сделана до переезда сайта, а в ней было просто http. Я подкорректировал адрес в старой закладке - добавил S

htpps.jpg
хоть с S хоть без S разницы нет , как только жму на филдер , сразу выкидывает
Вложения
2017-12-14_164936.png
2017-12-14_164953.png
Олег
https://yadi.sk/d/o6slUfa03MS2wX инструкции качаем тут
Toyota Corolla Fielder 2008г. ZRE142G V-1.8 "S" белый или просто "ФИЛЯ"
Аватара пользователя
panfiloff
Администратор
Черный бумер
Сообщения: 1150
Зарегистрирован: 26 дек 2009, 15:43
Откуда: Россия, Новосибирск
Благодарил (а): 32 раза
Поблагодарили: 17 раз
Контактная информация:

14 дек 2017, 17:07

kudrik34 писал(а): хоть с S хоть без S разницы нет , как только жму на филдер , сразу выкидывает
“Жму на филдер». - имеется в виду логотип в правой части шапки? Не должно выкидывать. Во всех браузерах такое, или в каком-то одном.? Инструкция выше не помогает?
Toyota Corolla Fielder 1.5 X, NZE-141, 1NZ, CVT, 2006
Аватара пользователя
kudrik34
Шофер
Сообщения: 676
Зарегистрирован: 06 окт 2013, 14:48
Откуда: Карасук НСО
Благодарил (а): 4 раза
Поблагодарили: 11 раз

14 дек 2017, 18:14

все верно , на логотип , в эксплорере все ок, ни че не пойму , куки и кеш читсил за все время , не помогает
Олег
https://yadi.sk/d/o6slUfa03MS2wX инструкции качаем тут
Toyota Corolla Fielder 2008г. ZRE142G V-1.8 "S" белый или просто "ФИЛЯ"
Аватара пользователя
kudrik34
Шофер
Сообщения: 676
Зарегистрирован: 06 окт 2013, 14:48
Откуда: Карасук НСО
Благодарил (а): 4 раза
Поблагодарили: 11 раз

14 дек 2017, 18:23

PS. Разобрался , хром блокировал сокеты форума ( видать я их добавил в блокировку, удалил их с блокировки разрешил им доступ и вуаля )))
Олег
https://yadi.sk/d/o6slUfa03MS2wX инструкции качаем тут
Toyota Corolla Fielder 2008г. ZRE142G V-1.8 "S" белый или просто "ФИЛЯ"
Аватара пользователя
panfiloff
Администратор
Черный бумер
Сообщения: 1150
Зарегистрирован: 26 дек 2009, 15:43
Откуда: Россия, Новосибирск
Благодарил (а): 32 раза
Поблагодарили: 17 раз
Контактная информация:

14 дек 2017, 19:54

kudrik34 писал(а):
14 дек 2017, 18:23
PS. Разобрался , хром блокировал сокеты форума ( видать я их добавил в блокировку, удалил их с блокировки разрешил им доступ и вуаля )))
Ну вот еще одно доказательство того, что основная часть проблем со входом и работой на сайте форума - из-за индивидуальных настроек того или иного браузера. Надо просто найти, где-что блокируется, убрать это, почистить и т.п. - и, скорее всего, все заработает на «ура» :dan_ser:
Toyota Corolla Fielder 1.5 X, NZE-141, 1NZ, CVT, 2006
Закрыто